PHP is amongst the most commonly used class-based programming languages. It is pretty popular as it’s free software, which can be used to set up interactive sites such as social networking websites, e-stores or online learning portals rather than static HTML websites. A PHP module should be installed on the web server where a PHP-driven site is hosted so that its PHP code can be ‘decoded’. Because there are no license fees for this kind of module and the language itself provides infinite possibilities for the web applications that you create, there are 100s of millions of PHP-driven sites. Additionally, there are an enormous number of PHP-based scripts, which you can use for your sites without having to possess any coding capabilities. Given the fact that there’re several versions of PHP, you should verify whether the exact same version that you used whilst developing your website is present on the server as well.

PHP 4 and PHP 5 Support in Hosting

With our Linux hosting plans, you’ll be able to select the PHP version that will be enabled for your web hosting account, since we support different versions. With as little as one mouse click, you will be able to switch between PHP 4, 5.2, 5.3, 5.4 and 5.5 and anytime a new version is released in the future, we will include it in the Hepsia Control Panel without removing the older versions. In this way, you’ll be able to host all the websites that you’ve developed throughout the years. In stark contrast to many other hosting vendors, we won’t force you to update such websites, because a script may be out of date, but this does not automatically mean that it is insecure since you may have done modifications to its code to fix security holes. For your convenience, you will even be able to specify a different PHP version for each website hosted in your hosting account.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

In case you have a website built using an older PHP version and you have donated time and energy towards setting it up, repairing safety breaches and adding web page content, you will need to find a hosting service that can support it, since the vast majority of web hosting vendors these days offer support only for the most recently released PHP version and drop the earlier ones. We, however, have decided to let you pick the exact version that your own websites require. Our Linux semi-dedicated servers support PHP 4 and multiple versions of PHP 5, so you’ll be able to use both newer and older scripts without forfeiting any custom modifications or misspending time and efforts struggling to make your websites compatible with the web hosting environment. The current version can be changed from the Hepsia hosting Control Panel and such an update will affect the whole semi-dedicated account, but you will also be able to pick a different version for each single site hosted in your account using an .htaccess config file.